Spatial |
Returns the boundary segments.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public IList<IList<BoundarySegment>> GetBoundarySegments(
SpatialElementBoundaryOptions options
)
Parameters
- options SpatialElementBoundaryOptions
- The SpatialElementBoundaryOptions.
Return Value
IList IList BoundarySegment
This method is used to retrieve the segments that constitute the boundary of the spatial element. Each spatial element may have several regions, each of which have several segments hence the data is returned in the form of an array of boundary segment arrays. See the BoundarySegment object for more details about the segments that make up the spatial element topology.