AssetPropertyList Class


Asset Property List Class

Represents a list of AssetProperty(s).
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.Visual AssetProperty
Autodesk.Revit.DB.Visual AssetPropertyList

Namespace: Autodesk.Revit.DB.Visual
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class AssetPropertyList : AssetProperty

The AssetPropertyList type exposes the following members.

Properties
Name Description
Top
Methods
Name Description
Public method AddNewAssetAsColor Adds a new AssetPropertyDouble4 property to the list containing a value matching the input color.
Public method AddNewAssetPropertyDouble Adds a new AssetPropertyDouble containing the input value to this list.
Public method AddNewAssetPropertyInteger Adds a new AssetPropertyInteger containing the input value to this list.
Public method GetValue Gets a collection of properties stored in this property list. These properties are copied.
Public method InsertNewAssetAsColor Insert a new AssetPropertyDouble4 containing the input value to this list.
Public method InsertNewAssetPropertyDouble Inserts a new AssetPropertyDouble containing the input value to this list.
Public method InsertNewAssetPropertyInteger Insert a new AssetPropertyInteger containing the input value to this list.
Public method IsValidValue
Public method RemoveAssetProperty Remove the AssetProperty from the list.
Public method SetValue
Top
See Also