StructuralMaterialTypeFilter Class


Structural Material Type Filter Class

A filter used to match family instances that have the given structural material type.
Inheritance Hierarchy

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class StructuralMaterialTypeFilter : ElementSlowFilter

The StructuralMaterialTypeFilter type exposes the following members.

Constructors
Name Description
Public method StructuralMaterialTypeFilter(StructuralMaterialType) Constructs a new instance of a filter to match family instances that have the given structural material type.
Public method StructuralMaterialTypeFilter(StructuralMaterialType, Boolean) Constructs a new instance of a filter to match family instances by structural material type, with the option to match all families which are not of the given structural material type.
Top
Properties
Name Description
Public property StructuralMaterialType The structural material type.
Top
Methods
Name Description
Top
Remarks
This filter is a slow filter, but it uses a quick filter to eliminate non-candidate elements before the elements are obtained and expanded. Therefore this filter does not have to be paired with another quick filter to minimize the number of Elements that are expanded.
See Also