StructuralMaterialTypeFilter Class


Structural Material Type Filter Class

A filter used to match family instances that have the given structural material type.
Inheritance Hierarchy

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class StructuralMaterialTypeFilter : ElementSlowFilter

The StructuralMaterialTypeFilter type exposes the following members.

Constructors
Name Description
Public method StructuralMaterialTypeFilter(StructuralMaterialType) Constructs a new instance of a filter to match family instances that have the given structural material type.
Public method StructuralMaterialTypeFilter(StructuralMaterialType, Boolean) Constructs a new instance of a filter to match family instances by structural material type, with the option to match all families which are not of the given structural material type.
Top
Properties
Name Description
Public property Inverted True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted.
(Inherited from ElementFilter )
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
(Inherited from ElementFilter )
Public property StructuralMaterialType The structural material type.
Top
Methods
Name Description
Public method Dispose
(Inherited from ElementFilter )
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method PassesFilter(Element) Applies the filter to a given element.
(Inherited from ElementFilter )
Public method PassesFilter(Document, ElementId) Applies the filter to a given element.
(Inherited from ElementFilter )
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
Remarks
This filter is a slow filter, but it uses a quick filter to eliminate non-candidate elements before the elements are obtained and expanded. Therefore this filter does not have to be paired with another quick filter to minimize the number of Elements that are expanded.
See Also