MEPConnectorInfo Class


MEPConnector Info Class

MEP connector information.
Inheritance Hierarchy

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class MEPConnectorInfo : IDisposable

The MEPConnectorInfo type exposes the following members.

Properties
Name Description
Public property IsPrimary True if this is the primary connector.
Public property IsSecondary True if this is the secondary connector.
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public property LinkedConnector The linked connector or if there is no linked connector
Top
Methods
Name Description
Public method Dispose Releases all resources used by the MEPConnectorInfo
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
See Also