DocumentChangedEventArgs Class


Document Changed Event Args Class

The event arguments used by the DocumentChanged event.
Inheritance Hierarchy

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class DocumentChangedEventArgs : RevitAPISingleEventArgs

The DocumentChangedEventArgs type exposes the following members.

Properties
Name Description
Public property Operation The operation associated with this event
Top
Methods
Name Description
Public method GetAddedElementIds Returns set of elements newly added to the document.
Public method GetAddedElementIds(ElementFilter) Returns set of newly added elements that pass the filter.
Public method GetDeletedElementIds Returns set of elements that were deleted from the document.
Public method GetDocument Returns document associated with this event
Public method GetModifiedElementIds Returns set of elements that were modified.
Public method GetModifiedElementIds(ElementFilter) Returns set of elements that were modified according to the given element filter.
Public method GetTransactionNames Returns names of the transactions associated with this event
Top
See Also