BuiltInFailures.StructuralCustomConnectionFailures Class


Built In Failures Structural Custom Connection Failures Class

Failures about StructuralConnectionHandler.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB BuiltInFailures StructuralCustomConnectionFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static class StructuralCustomConnectionFailures

The BuiltInFailures StructuralCustomConnectionFailures type exposes the following members.

Properties
Name Description
Public property Static member SimpleConnectionTooFarRefs Simple Structural Connection Handler cannot connect too far elements
Public property Static member StructuralCannotCreateCustomConnection Could not create a custom connection.
Public property Static member StructuralCustomConnectionComponentsRelationship Cannot create custom connection due to relationships to external elements.
Public property Static member StructuralCustomConnectionEmpty Structural Custom Connection cannot be empty.
Public property Static member StructuralCustomConnectionWrongType Structural Custom Connection has an inappropriate type assigned.
Top
See Also