Analysis |
Contains all information about one analysis result. Each result may contain several measurements.

System Object
Autodesk.Revit.DB.Analysis AnalysisResultSchema
Autodesk.Revit.DB.Analysis AnalysisResultSchema
Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)

The AnalysisResultSchema type exposes the following members.

Name | Description | |
---|---|---|
![]() | AnalysisResultSchema(AnalysisResultSchema) | Constructs a new copy of the input AnalysisResultSchema object. |
![]() | AnalysisResultSchema(String, String) | Creates object and assigns name and description |

Name | Description | |
---|---|---|
![]() | AnalysisDisplayStyleId | ElementId of analysis display style overriding the style set for view; -1 if the style is not overridden |
![]() | CurrentUnits | Stores the index in the array of applicable units |
![]() | Description | Description of analysis result in view |
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. |
![]() | IsVisible | If true analysis result is visible in view |
![]() | Name | Name of analysis result in view |
![]() | Scale | Multiplier used for displaying diagram or vector values in view. |

Name | Description | |
---|---|---|
![]() | Dispose | Releases all resources used by the AnalysisResultSchema |
![]() | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object ) |
![]() | GetHashCode | Serves as the default hash function. (Inherited from Object ) |
![]() | GetNumberOfUnits | returns number of possible units |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object ) |
![]() | GetUnitsMultiplier | returns units multiplier by index |
![]() | GetUnitsName | returns units name by index |
![]() | IsEqual | Determines if the input object is equivalent to this AnalysisResultSchema. |
![]() | SetUnits | |
![]() | ToString | Returns a string that represents the current object. (Inherited from Object ) |

In order to take effect, the AnalysisResultSchema object has to be registered by calling SpatialFieldManager::RegisterResult, which returns result index for future references; to make changes to the properties of an already registered object, use method SpatialFieldManager::SetResultSchema and supply result index and replacing object.