FilterOperatorAndTextString Class


Filter Operator And Text String Class

An instance of this class holds a filter operator and a text string that denotes the operator in a particular context. For example, the text string for ScheduleFilterType::LessThan may be "is less than" for a filter rule based on a parameter with numerical values or "is below" for a filter rule based on a parameter representing a Level.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB FilterOperatorAndTextString

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class FilterOperatorAndTextString : IDisposable

The FilterOperatorAndTextString type exposes the following members.

Properties
Name Description
Public property FilterOperatorStr A text string denoting the filter operator.
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public property OperatorType The filter operator.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the FilterOperatorAndTextString
Top
See Also