Double |
Provides access to settings that control what happens when the current user double-clicks on an element.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)

The DoubleClickOptions type exposes the following members.

Name | Description | |
---|---|---|
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. |

Name | Description | |
---|---|---|
![]() | Dispose | Releases all resources used by the DoubleClickOptions |
![]() | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object ) |
![]() | GetAction | Returns the active user's desired action for a particular double-click target. |
![]() ![]() | GetDoubleClickOptions | Returns the current user's DoubleClickOptions. |
![]() | GetHashCode | Serves as the default hash function. (Inherited from Object ) |
![]() | GetRenameOnSlowDoubleClickInProjectBrowser | Returns the user's desire to rename item in project browser on slow double-click. |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object ) |
![]() | IsSupportedAction | Checks whether the specified double-click target supports the specified action. |
![]() | SetAction | Changes the double-click action associated with a specified target. |
![]() | SetRenameOnSlowDoubleClickInProjectBrowser | Sets whether the desired action is to rename item in project browser on slow double-click. |
![]() | ToString | Returns a string that represents the current object. (Inherited from Object ) |

These settings are stored on a per-user basis. Revit will follow these settings for all projects and families for this user.