WorksharedOperationProgressChanged Event


Controlled Application Workshared Operation Progress Changed Event

# Subscribe to the WorksharedOperationProgressChanged to be notified when progress has changed during Collaboration for Revit's workshared operations: open model and synchronize with central.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public event EventHandler<WorksharedOperationProgressChangedEventArgs> WorksharedOperationProgressChanged

Value

EventHandler WorksharedOperationProgressChangedEventArgs
Remarks

This event is only supported for Collaboration for Revit and will not be raised for those operations occurring in local-worksharing and Revit Server workflow. Users may not change the document in the handler for this event. If you do not need detailed progress information for synchronizing with central, see [!:Autodesk::Revit::DB::Events::DocumentSynchronizingWithCentral] or [!:Autodesk::Revit::DB::Events::DocumentSynchronizedWithCentral] . It is NOT recommended to do any time-consuming work when handling DocumentSynchronizingWithCentralProgessChanged event. This can increase workshared operation time." Exception ModificationForbiddenException will be thrown if any document-modifying method is called during this event's handler.

See Also