IExternalServer Interface


IExternal Server Interface

The base interface for all external servers.

Namespace: Autodesk.Revit.DB.ExternalService
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public interface IExternalServer

The IExternalServer type exposes the following members.

Methods
Name Description
Public method GetDescription Implement this method to return a description of the server.
Public method GetName Implement this method to return the name of the server.
Public method GetServerId Implement this method to return the id of the server.
Public method GetServiceId Implement this method to return the id of the service.
Public method GetVendorId Implement this method to return the id of the vendor of the server.
Top
Remarks
Every external service in Revit declares a specific interface for its servers. Each interface must be derived from this IExternalServer. Providers of external servers implement the server interfaces defined by the respective external services to which the servers belong. The whole process of creating a server and registering it with Revit as a server of a concrete external service can be outlined in the following steps:
  1. A provider of an external service declares a server interface derived from IExternalServer
  2. The provider of the service will make it known that this interface is for the servers of that service
  3. An application wanting to have a server will implement the appropriate interface
  4. The server's application obtains the service from Revit using the ExternalServiceRegistry.GetService method
  5. An instance of the server class can then be registered with Revit by using the ExternalService.AddServer method
See Also