Create Method


View Drafting Create Method

Creates a new ViewDrafting in the model.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public static ViewDrafting Create(
	Document document,
	ElementId viewFamilyTypeId
)

Parameters

document Document
The document in which the new drafting view will be created.
viewFamilyTypeId ElementId
The id of the ViewFamilyType that should be assigned to the new drafting view.

Return Value

ViewDrafting
The newly created drafting view.
Exceptions
Exception Condition
ArgumentException viewFamilyTypeId is not a valid ViewFamilyType for a drafting view.
ArgumentNullException A non-optional argument was null
See Also