Wood Class


Wood Class

A static class that provides access to the property names that appear in the Wood visual asset schema.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.Visual Wood

Namespace: Autodesk.Revit.DB.Visual
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static class Wood

The Wood type exposes the following members.

Properties
Name Description
Public property Static member TextureAngle The property labeled "Angle" from the "Wood" schema.
Public property Static member TextureLinkTextureTransforms The property labeled "Link Transforms" from the "Wood" schema.
Public property Static member TextureRealWorldOffsetX The property labeled "Offset X" from the "Wood" schema.
Public property Static member TextureRealWorldOffsetY The property labeled "Offset Y" from the "Wood" schema.
Public property Static member TextureRealWorldOffsetZ The property labeled "Offset Z" from the "Wood" schema.
Public property Static member WoodAxialNoise The property labeled "Axial Noise" from the "Wood" schema.
Public property Static member WoodColor1 The property labeled "Color 1" from the "Wood" schema.
Public property Static member WoodColor2 The property labeled "Color 2" from the "Wood" schema.
Public property Static member WoodRadialNoise The property labeled "Radial Noise" from the "Wood" schema.
Public property Static member WoodThickness The property labeled "Grain Thickness" from the "Wood" schema.
Top
See Also