SpatialFieldPrimitiveHideMode Enumeration


Spatial Field Primitive Hide Mode Enumeration

Defines modes which can be used by a SpatialFieldPrimitive to hide the original referenced element.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public enum SpatialFieldPrimitiveHideMode
Members
Member name Value Description
Default 0 For ColoredSurface display style, hide only the referenced face passed at the primitive creation time. For DeformedShape display style, hide only the referenced face or curve passed at the primitive creation time.
HideNone 1 Do not hide any piece of the original model element.
HideOnlyReference 2 Hide only the referenced face or curve.
HideWholeElement 3 Hide the whole referenced element.
See Also