Create |
The event arguments used during creating related file phase of [!:Autodesk::Revit::ApplicationServices::Application::WorksharedOperationProgressChanged] in model open operation.

System Object
System EventArgs
Autodesk.Revit.DB.Events RevitAPIEventArgs
Autodesk.Revit.DB.Events RevitAPISingleEventArgs
Autodesk.Revit.DB.Events WorksharedOperationProgressChangedEventArgs
Autodesk.Revit.DB.Events DataTransferProgressChangedEventArgs
Autodesk.Revit.DB.Events CreateRelatedFileProgressChangedEventArgs
System EventArgs
Autodesk.Revit.DB.Events RevitAPIEventArgs
Autodesk.Revit.DB.Events RevitAPISingleEventArgs
Autodesk.Revit.DB.Events WorksharedOperationProgressChangedEventArgs
Autodesk.Revit.DB.Events DataTransferProgressChangedEventArgs
Autodesk.Revit.DB.Events CreateRelatedFileProgressChangedEventArgs
Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The CreateRelatedFileProgressChangedEventArgs type exposes the following members.

Name | Description | |
---|---|---|
![]() | Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitAPIEventArgs ) |
![]() | CreatingCloudSharedLocal | Indicates if it is creating cloud shared local model. |
![]() | DownloadFinished | Indicates if all data downloads are finished. |
![]() | FinishedSize | The transferred data size, in bytes, since the last time this event was raised. (Inherited from DataTransferProgressChangedEventArgs ) |
![]() | FullDownload | Indicates if download the full data of the document, which will take longer than subsequent downloads. |
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from RevitAPIEventArgs ) |
![]() | Location | Full path of the central model which is to be operated. (Inherited from WorksharedOperationProgressChangedEventArgs ) |
![]() | Speed | Speed(bytes/second) in this event. (Inherited from DataTransferProgressChangedEventArgs ) |
![]() | Status | Gets API event status, reflect current operation execution status. (Inherited from WorksharedOperationProgressChangedEventArgs ) |
![]() | TotalSize | Total expected data size to transfer, in bytes. (Inherited from DataTransferProgressChangedEventArgs ) |
![]() | TransferMode | Data transfer mode in this event. (Inherited from DataTransferProgressChangedEventArgs ) |

Name | Description | |
---|---|---|
![]() | Dispose | (Inherited from RevitAPIEventArgs ) |
![]() | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object ) |
![]() | GetHashCode | Serves as the default hash function. (Inherited from Object ) |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object ) |
![]() | IsCancelled | Indicates whether the event is being cancelled. (Inherited from RevitAPIEventArgs ) |
![]() | ToString | Returns a string that represents the current object. (Inherited from Object ) |