Create |
The event arguments used during creating related file phase of [!:Autodesk::Revit::ApplicationServices::Application::WorksharedOperationProgressChanged] in model open operation.

System Object
System EventArgs
Autodesk.Revit.DB.Events RevitAPIEventArgs
Autodesk.Revit.DB.Events RevitAPISingleEventArgs
Autodesk.Revit.DB.Events WorksharedOperationProgressChangedEventArgs
Autodesk.Revit.DB.Events DataTransferProgressChangedEventArgs
Autodesk.Revit.DB.Events CreateRelatedFileProgressChangedEventArgs
System EventArgs
Autodesk.Revit.DB.Events RevitAPIEventArgs
Autodesk.Revit.DB.Events RevitAPISingleEventArgs
Autodesk.Revit.DB.Events WorksharedOperationProgressChangedEventArgs
Autodesk.Revit.DB.Events DataTransferProgressChangedEventArgs
Autodesk.Revit.DB.Events CreateRelatedFileProgressChangedEventArgs
Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The CreateRelatedFileProgressChangedEventArgs type exposes the following members.

Name | Description | |
---|---|---|
![]() | CreatingCloudSharedLocal | Indicates if it is creating cloud shared local model. |
![]() | DownloadFinished | Indicates if all data downloads are finished. |
![]() | FullDownload | Indicates if download the full data of the document, which will take longer than subsequent downloads. |

Name | Description | |
---|---|---|