GetActivePredefinedSettings Method


Export DWGSettings Get Active Predefined Settings Method

Returns the active pre-defined non-in-session exporting settings for DWG in the given document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static ExportDWGSettings GetActivePredefinedSettings(
	Document aDoc
)

Parameters

aDoc Document
A Revit document to retrieve the active pre-defined exporting settings for DWG.

Return Value

ExportDWGSettings
The active pre-defined exporting settings for DWG, or null if nothing pre-defined exists or the in-session settings is selected.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
See Also