NewSpaces2 Method (Level, Phase, View)


Document New Spaces 2(Level, Phase, View) Method

Creates new spaces on the available plan circuits of a the given level.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public ICollection<ElementId> NewSpaces2(
	Level level,
	Phase phase,
	View view
)

Parameters

level Level
The level on which the spaces is to exist.
phase Phase
The phase in which the spaces is to exist.
view View
The view on which the space tags for the spaces are to display.

Return Value

ICollection ElementId
If successful, a set of ElementIds which contains the rooms should be returned, otherwise the exception will be thrown.
Exceptions
Exception Condition
ArgumentOutOfRangeException The view of the relevant level can not be retrieved.
InvalidOperationException The phase is invalid or regeneration fails at the end of the creation.
ArgumentException Thrown if the level does not exist in the given document.
ArgumentException Thrown if the phase does not exist in the given document.
ArgumentException Thrown if the view does not exist in the given document.
Remarks
This method will regenerate the document even in manual regeneration mode.
See Also