RenderingImageExposureSettings Class


Rendering Image Exposure Settings Class

Represents the exposure settings of rendering.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB RenderingImageExposureSettings

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class RenderingImageExposureSettings : IDisposable

The RenderingImageExposureSettings type exposes the following members.

Properties
Name Description
Public property ExposureValue The value of rendering image exposure.
Public property Highlights The highlights value.
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public property Saturation The value of rendering image saturation.
Public property Shadows The shadows value.
Public property WhitePoint The white point value.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the RenderingImageExposureSettings
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
See Also