BalusterInfo Class


Baluster Info Class

The class represents an instance of a railing baluster or post.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.Architecture BalusterInfo

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class BalusterInfo : IDisposable

The BalusterInfo type exposes the following members.

Properties
Name Description
Public property BalusterFamilyId The id of the family used for the baluster or post.
Public property BaseOffset The offset from the base reference.
Public property BaseReferenceName Represents the name of the reference for the bottom of this baluster or post.
Public property DistanceFromPreviousOrSpace The length, in case of balusters, it is a distance from a previous one. For a post, it is a space from the original position of the post.
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public property Name The name of the baluster.
Public property Offset The side offset of the baluster/post from the railing path.
Public property TopOffset The offset from the top reference.
Public property TopReferenceName Represents the name of the reference for the top of this baluster or post.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the BalusterInfo
Public method Static member GetReferenceNameForHost Gets the name string to be used as a reference to Host in the current language.
Public method Static member GetReferenceNameForTopRail Gets the name string to be used as a reference to Top Rail in the current language.
Top
See Also