Document
Import(String, OBJImport
|
Imports an OBJ file into the document.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)

Parameters
- file String
- Full path of the file to import. File must exist and must be a valid OBJ file.
- options OBJImportOptions
- Various import options applicable to the OBJ format. If , all options will be set to their respective default values.
- pDBView View
- View used to aid placement of the imported file. If the options specify ThisViewOnly, this argument is required and the imported file will only be visible in the specified view. If the options specify center-to-center placement, this argument is required and the imported file will be placed in the center of the specified view. Otherwise, this view is used to obtain a base level to associate with the imported file. If not specified, an existing view will be chosen instead and may open a view or associate the imported file to an arbitrary level.
Return Value
ElementIdReturns the element Id of the imported instance.

Exception | Condition |
---|---|
ArgumentException | Not a valid file for OBJ import (.obj files are valid). -or- ThisViewOnly cannot be true when importing a DWG|DGN drawing into a 3D view. -or- The provided view is not valid for the options provided. -or- One or more strings describing layer selection is invalid or empty. -or- The scale is not valid as a CustomScale for use during import. -or- NullOrEmpty -or- The view is not printable. |
ArgumentNullException | A non-optional argument was null |
FileArgumentNotFoundException | The given file does not exist. |
InvalidOperationException | Import is temporarily disabled. |
ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process. |
ModificationOutsideTransactionException | The document has no open transaction. |
OptionalFunctionalityNotAvailableException | The Material Library is missing in the installed Revit. -or- The OBJ Import/Link module is not available in the installed Revit. |