IExternalDBApplication Interface


IExternal DBApplication Interface

An interface that supports addition of DB-level external applications to Revit, to subscribe to DB-level events and updaters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public interface IExternalDBApplication

The IExternalDBApplication type exposes the following members.

Methods
Name Description
Public method OnShutdown Implement this method to execute some tasks when Autodesk Revit shuts down.
Public method OnStartup Implement this method to execute some tasks when Autodesk Revit starts.
Top
Remarks
DB-level applications are permitted to add DB-level events and updaters to the session. They cannot create or modify UI.
See Also