ScheduleFilter Constructor (ScheduleFieldId, ScheduleFilterType, Int32)


Schedule Filter(Schedule Field Id, Schedule Filter Type, Int 32) Constructor

Creates a new ScheduleFilter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public ScheduleFilter(
	ScheduleFieldId fieldId,
	ScheduleFilterType filterType,
	int value
)

Parameters

fieldId ScheduleFieldId
The ID of the field used to filter the schedule.
filterType ScheduleFilterType
The filter type.
value Int32
The filter value for a filter using an integer value.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
ArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration
See Also