NewRoomTag Method


Document New Room Tag Method

Creates a new RoomTag referencing a room in the host model or in a Revit link.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public RoomTag NewRoomTag(
	LinkElementId roomId,
	UV point,
	ElementId viewId
)

Parameters

roomId LinkElementId
The HostOrLinkElementId of the Room.
point UV
A 2D point that defines the tag location on the level of the room.
viewId ElementId
The id of the view where the tag will be shown. If and the room in not in a Revit link, the view of the room will be used.

Return Value

RoomTag
If successful a RoomTag object will be returned, otherwise .
Exceptions
Exception Condition
ArgumentException viewId is not associated with a plan view or section view.
InvalidOperationException viewId is null and the room is in a linked file.
See Also