ViewDisplayModel Class


View Display Model Class

Represents the settings for displaying model graphics. version 2: m_showHiddenLines type changed bool -> ShowHiddenLinesValues::Enum
Inheritance Hierarchy
System Object
Autodesk.Revit.DB ViewDisplayModel

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class ViewDisplayModel : IDisposable

The ViewDisplayModel type exposes the following members.

Properties
Name Description
Public property EnableSilhouettes True to show silhouettes edges. False to disable showing them.
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public property ShowHiddenLines True to enable hidden lines. False to disable showing them.
Public property SilhouetteEdgesGStyleId Style ID for silhouette edges
Public property SmoothEdges True to enable "smooth edge" (anti-aliasing) effect. False to disable it.
Public property Transparency The percentage (0..100) of surface transparency 0 means the surfaces are opaque, 100 means they are fully transparent
Top
Methods
Name Description
Public method Dispose Releases all resources used by the ViewDisplayModel
Top
See Also