RebarSpliceTypeUtils Class


Rebar Splice Type Utils Class

Utility class for dealing with Rebar Splice Type operations. To find all Rebar Splice Types in the document can be done using FilteredElementCollector of category BuiltInCategory.OST_RebarSpliceType.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.Structure RebarSpliceTypeUtils

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static class RebarSpliceTypeUtils

The RebarSpliceTypeUtils type exposes the following members.

Methods
Name Description
Public method Static member CreateRebarSpliceType Creates a Rebar Splice Type element.
Public method Static member GetAllRebarSpliceTypes Gets all the Rebar Splice Types elements from the document.
Public method Static member GetLapLengthMultiplier Gets the lap length multiplier value.
Public method Static member GetShiftOption Identifies the way bars are shifted in the splice relation.
Public method Static member GetStaggerLengthMultiplier Gets the stagger multiplier value.
Public method Static member SetLapLengthMultiplier Sets the lap length multiplier value.
Public method Static member SetShiftOption Sets the way bars are shifted in the splice relation.
Public method Static member SetStaggerLengthMultiplier Sets the lap length multiplier value.
Top
See Also