Rebar |
Adds a new rebar geometry. This information is set to the rebar after the API execution is finished successfully.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- curves CurveLoop
- Curves describing one bar in the set.
Return Value
RebarFreeFormValidationResultReturns Success if everything is ok, otherwise the failure reason.

Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was null |
InvalidOperationException | Incorrect number of bar geometry. |

This function can fail due to following reasons:
- CurveLoop is empty.
- CurveLoop contains an unbounded curve.
- A rebar constructed from curves can't be bent according to the bending radius.