WorksharingDisplayGraphicSettings Class


Worksharing Display Graphic Settings Class

Represents the graphical settings that can be assigned to elements in the worksharing display modes.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB WorksharingDisplayGraphicSettings

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class WorksharingDisplayGraphicSettings : IDisposable

The WorksharingDisplayGraphicSettings type exposes the following members.

Constructors
Name Description
Public method WorksharingDisplayGraphicSettings Creates a new instance.
Top
Properties
Name Description
Public property FillColor The fill color that will be applied to elements when these settings are applied. Note that this is automatically set by increasing the luma of the specified line color by 65%.
Public property IsApplied Indicates whether this set of graphic overrides will be applied.
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public property LineColor The line color that will be applied to elements when these settings are applied.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the WorksharingDisplayGraphicSettings
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
See Also