RepeaterBounds Class


Repeater Bounds Class

Represents bounds of the array of repeating references in 0, 1, or 2 dimensions. (See RepeatingReferenceSource ).
Inheritance Hierarchy
System Object
Autodesk.Revit.DB RepeaterBounds

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class RepeaterBounds : IDisposable

The RepeaterBounds type exposes the following members.

Properties
Name Description
Public property DimensionCount The number of dimensions of the bounds (0, 1 or 2 for zero, one or two dimensional arrays.)
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
Name Description
Public method AdjustForCyclicalBounds Shifts the input coordinates in the cyclical dimensions so that they fall in the [lower bounds, upper bounds] range.
Public method AreCoordinatesInBounds Determines whether given coordinates are within the bounds.
Public method Dispose Releases all resources used by the RepeaterBounds
Public method GetLowerBound Returns the smallest index of the array in the given dimension.
Public method GetUpperBound Returns the highest index of the array in the given dimension.
Public method IsCyclical True if the array doesn't have finite bounds in the given dimension. Cyclical bounds indicate that the array forms a closed loop in the given dimension.
Top
See Also