SelectionChanged Event


UIApplication Selection Changed Event

Subscribe to the SelectionChanged event to be notified after the selection was changed.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public event EventHandler<SelectionChangedEventArgs> SelectionChanged

Value

EventHandler SelectionChangedEventArgs
Remarks

This event is raised after the selection was changed in the current document. Handlers of this event are forbidden to make modifications to the current document. Handlers of this event are forbidden to change the selection to the current document. It is not allowed to open a new transaction in the active document when handling this event.

See Also