ISelection |
Override this pre-filter method to specify if the element should be permitted to be selected.
Namespace: Autodesk.Revit.UI.Selection
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- elem Element
- A candidate element in selection operation.
Return Value
BooleanReturn true to allow the user to select this candidate element. Return false to prevent selection of this element.

If prompting the user to select an element from a Revit Link instance, the element passed here will be the link instance, not the selected linked element. Access the linked element from Reference passed to the AllowReference() callback of ISelectionFilter.
If an exception is thrown from this method, the element will not be permitted to be selected.