PrimaryDesignOptionMemberFilter Class


Primary Design Option Member Filter Class

A filter used to find elements contained in any primary design option of any design option set.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB ElementFilter
Autodesk.Revit.DB ElementSlowFilter
Autodesk.Revit.DB PrimaryDesignOptionMemberFilter

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class PrimaryDesignOptionMemberFilter : ElementSlowFilter

The PrimaryDesignOptionMemberFilter type exposes the following members.

Constructors
Name Description
Public method PrimaryDesignOptionMemberFilter Constructs a new instance of a filter to match elements contained in any primary design option of any design option set.
Public method PrimaryDesignOptionMemberFilter(Boolean) Constructs a new instance of a filter to match elements contained in any primary design option of any design option set, with the option to invert the filter and find elements not contained in any primary design option of any design option set.
Top
Properties
Name Description
Top
Methods
Name Description
Top
Remarks
This filter will only pass elements in a primary design option. It will not pass elements in the main model not associated to any design option. This filter is a slow filter. Slow filters require that the Element be obtained and expanded in memory first. Thus it is preferable to couple this filter with at least one ElementQuickFilter, which should minimize the number of Elements that are expanded.
See Also