Change |
Enum used to specify the priority of an Updater during execution.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)


Member name | Value | Description |
---|---|---|
Annotations | 16 | Updater will modify annotations |
Connections | 10 | Updater will modify connections |
DetailComponents | 15 | Updater will modify detail components and symbolic lines |
DoorsOpeningsWindows | 5 | Updater will modify family instances that cut their hosts like doors and windows |
FloorsRoofsStructuralWalls | 2 | Updater will modify exterior shell of the building or floor slabs |
FreeStandingComponents | 9 | Updater will modify standalone components |
GridsLevelsReferencePlanes | 0 | Updater will modify core datums and major reference planes |
InteriorWalls | 4 | Updater will modify interior/partition walls |
Masses | 1 | Updater will modify masses |
MEPAccessoriesFittingsSegmentsWires | 12 | Updater will modify MEP elements such as segments, fittings and wires |
MEPCalculations | 8 | Updater will update MEP calculated values |
MEPFixtures | 6 | Updater will modify MEP fixtures such as lights, sinks, equipment, etc. |
MEPSystems | 13 | Updater will modify MEP systems or circuits |
Rebar | 11 | Updater will modify rebar |
RoomsSpacesZones | 7 | Updater will modify Rooms, MEP spaces or zones |
Structure | 3 | Updater will modify structural elements like beams, braces, columns and trusses |
Views | 14 | Updater will modify views |

The enumeration values are ordered in the order in which updaters associated to each priority will be run. For example, updaters associated to priority GridsLevelsReferencePlanes will run first, while updaters associated to priority Annotations will run last.