Item Property (String)


Categories Item(String) Property

Gets a category which has the specified name from this list of top-level categories.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public override Category this[
	string name
] { get; set; }

Parameters

name String
The name of the category to be retrieved.

Property Value

Category
The category with the specified name.
Exceptions
Exception Condition
InvalidOperationException Thrown when the category list does not contain the category with this name. Thrown when trying to set an item to this list of categories; this list is read only.
See Also