Revision Combine |
Combines the specified Revision with the next Revision.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)

public static ISet<ElementId> CombineWithNext(
Document document,
ElementId revisionId
)
Parameters
- document Document
- The Document containing the Revisions.
- revisionId ElementId
- The Revision that should have its clouds and tags associated with the next Revision.
Return Value
ISet ElementIdThe ids of all RevisionClouds that were reassigned to the next Revision.

Exception | Condition |
---|---|
ArgumentException | revisionId is not a valid Revision. -or- This operation cannot be performed because revisionId is an issued Revision. -or- revisionId cannot be combined with the next Revision because either revisionId is the last Revision or the next Revision has already been issued. |
ArgumentNullException | A non-optional argument was null |

All RevisionClouds and tags associated with the specified Revision will be reassigned to the next Revision in the model and the specified Revision will be deleted from the model. The operation can only be performed if both the specified Revision and the next one are unissued.