NewFilterName Property


Filter Dialog New Filter Name Property

The name of the new ParameterFilterElement to be created and selected once Show is invoked.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public string NewFilterName { get; set; }

Property Value

String
Exceptions
Exception Condition
ArgumentException When setting this property: newFilterName is an empty string. -or- When setting this property: newFilterName cannot include prohibited characters, such as "{, }, [, ], |, ;, less-than sign, greater-than sign, ?, `, ~". -or- When setting this property: The supplied filter name newFilterName is not unique.
ArgumentNullException When setting this property: A non-optional argument was null
See Also