WorksetTable Class


Workset Table Class

A table containing references to all the worksets contained in a document.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB WorksetTable

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class WorksetTable : IDisposable

The WorksetTable type exposes the following members.

Properties
Name Description
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
Name Description
Public method Static member CanDeleteWorkset Indicates if a workset can be deleted.
Public method Static member DeleteWorkset Delete the specific workset.
Public method Dispose Releases all resources used by the WorksetTable
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method Code example GetActiveWorksetId Returns the active workset's WorksetId.
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method GetWorkset(Guid) Returns the workset from a input Guid.
Public method GetWorkset(WorksetId) Returns the workset from a input WorksetId.
Public method Static member IsWorksetNameUnique Checks if the given workset name is unique in the document.
Public method Static member RenameWorkset Renames the workset.
Public method SetActiveWorksetId Sets the active workset.
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
Remarks
There is one WorksetTable for each document. There will be at least one default workset in the table, even if worksharing has not been enabled in the document.
See Also