ValidateCurve Method


Wireframe Builder Validate Curve Method

Validates curve to be added to the wireframe shape being constructed. Used by addCurve to validate input. This function may be used to pre-validate the geometry being added to avoid an exception from AddCurve().

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static bool ValidateCurve(
	Curve GCurve
)

Parameters

GCurve Curve
Curve object to be validated.

Return Value

Boolean
True is %GCurve% is acceptable as a part of a wireframe shape representation being built.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
See Also