CreateSweptBlendGeometry Method (Curve, IList(Double), IList(CurveLoop), IList(ICollection(VertexPair)))


Geometry Creation Utilities Create Swept Blend Geometry(Curve, IList Double , IList Curve Loop , IList ICollection Vertex Pair ) Method


Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public static Solid CreateSweptBlendGeometry(
	Curve pathCurve,
	IList<double> pathParams,
	IList<CurveLoop> profileLoops,
	IList<ICollection<VertexPair>> vertexPairs
)

Parameters

pathCurve Curve
pathParams IList Double
profileLoops IList CurveLoop
vertexPairs IList ICollection VertexPair

Return Value

Solid
See Also