PushButtonData Class


Push Button Data Class

This class contains information necessary to construct a push button in the Ribbon.
Inheritance Hierarchy

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class PushButtonData : ButtonData

The PushButtonData type exposes the following members.

Constructors
Name Description
Public method PushButtonData Constructs a new instance of PushButtonData.
Top
Properties
Name Description
Public property AssemblyName The assembly path of the button.
Public property AvailabilityClassName The full class name for the class providing the entry point to decide availability of this push button.
Public property ClassName The name of the class containing the implementation for the command.
Top
Methods
Name Description
Top
See Also