SetSegmentHeight Method


View Schedule Set Segment Height Method

Sets the segment height.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void SetSegmentHeight(
	int segmentIndex,
	double height
)

Parameters

segmentIndex Int32
Index of the segment.
height Double
New height for the segment.
Exceptions
Exception Condition
ArgumentException segmentIndex must be between 0 and the last second of all segments.
ArgumentOutOfRangeException The given value for height must be greater than 0 and no more than 30000 feet.
Remarks
The height is Revit's internal units value of schedule header and segment body. The last segment can not set height. Its height will be determined by whole schedule height and other segments' heights. The height will not be the exact segment height on sheet. It will be the border height of the instance. The real height will be determined by the segment content. If the row cannot be shown within the instance boder, it will flow to the next segment.
See Also