FilterValueRule Class


Filter Value Rule Class

A rule that filters on a particular value of an element.
Inheritance Hierarchy

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class FilterValueRule : FilterRule

The FilterValueRule type exposes the following members.

Properties
Name Description
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
(Inherited from FilterRule )
Top
Methods
Name Description
Public method Dispose
(Inherited from FilterRule )
Public method ElementPasses Derived classes override this method to implement the test that determines whether the given element passes this rule or not.
(Inherited from FilterRule )
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetRuleParameter Returns the ElementId of the parameter associated to this FilterRule if there is one, or invalidElementId if there is no associated parameter.
(Inherited from FilterRule )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
See Also