Duct Set |
Updates the associated system type for the duct.
Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- systemTypeId ElementId
- The ElementId of the hvac system type.

Exception | Condition |
---|---|
ArgumentException | The systemTypeId is not valid HVAC system type. |
ArgumentNullException | A non-optional argument was null |

If the duct previously did not have a system associated to it, this will create a new system.