Adaptive |
Creates a FamilyInstance of Adaptive Component Family.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public static FamilyInstance CreateAdaptiveComponentInstance(
Document doc,
FamilySymbol famSymb
)
Parameters
- doc Document
- The Document
- famSymb FamilySymbol
- The FamilySymbol
Return Value
FamilyInstanceThe Family Instance

Exception | Condition |
---|---|
ArgumentException | The element famSymb was not found in the given document. -or- The Symbol famSymb is not an Adaptive Family Symbol. |
ArgumentNullException | A non-optional argument was null |
InvalidOperationException | Unable to create adaptive component instance. |

This method creates an Adaptive FamilyInstance and its PointElement references. The references can be accessed by methods like GetInstancePointElementRefIds(). The PointElement references can be moved, rehosted or manipulated just like any other PointElements. The FamilyInstance would then 'adapt' to these references.