Text |
Provides access to settings that control Revit's Text Editor appearance and functionality.

System Object
Autodesk.Revit.UI TextEditorOptions
Autodesk.Revit.UI TextEditorOptions
Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.3.0.0 (25.3.0.0)

The TextEditorOptions type exposes the following members.

Name | Description | |
---|---|---|
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. |
![]() | ShowBorder | Show the border box around the text during editing. |
![]() | ShowOpaqueBackground | Show opaque background behind the text during editing. |

Name | Description | |
---|---|---|
![]() | Dispose | Releases all resources used by the TextEditorOptions |
![]() ![]() | GetTextEditorOptions | Returns the current Revit instance's TextEditorOptions. |

These settings are stored in the Revit.ini file. All documents in Revit instances which use this Revit.ini will follow these settings.