Set Method (Double)


Parameter Set(Double) Method

Sets the parameter to a new real number value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public bool Set(
	double value
)

Parameters

value Double
The new double value to which the parameter is to be set.

Return Value

Boolean
The Set method will return True if the parameter was successfully set to the new value, otherwise false.
Exceptions
Exception Condition
InvalidOperationException The parameter is read-only.
ArgumentException Value must be a finite number.
Remarks
You should only use this method if the StorageType property reports the type of the parameter as a Double.
See Also