Vertex |
A geometry vertex specified as a position in space with a normal vector.

System Object
Autodesk.Revit.DB.DirectContext3D Vertex
Autodesk.Revit.DB.DirectContext3D VertexPositionNormal
Autodesk.Revit.DB.DirectContext3D Vertex
Autodesk.Revit.DB.DirectContext3D VertexPositionNormal
Namespace: Autodesk.Revit.DB.DirectContext3D
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The VertexPositionNormal type exposes the following members.

Name | Description | |
---|---|---|
![]() | VertexPositionNormal | Constructs the vertex from a point and a normal vector. |

Name | Description | |
---|---|---|
![]() | Normal | The vertex's normal vector. |
![]() | Position | The vertex's position. |

Name | Description | |
---|---|---|
![]() ![]() | GetSizeInFloats | Gets the amount of storage that the vertex takes up in a buffer, measured in floats. |

Since these vertices do not have a color their color is obtained from the EffectInstance