Context |
A class that owns context menu items.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)

The ContextMenu type exposes the following members.

Name | Description | |
---|---|---|
![]() | ContextMenu | Default constructor |

Name | Description | |
---|---|---|
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. |

Name | Description | |
---|---|---|
![]() | AddItem | Add an item to the Context Menu. |
![]() | Dispose | Releases all resources used by the ContextMenu |

There are three types of menu items ( CommandMenuItem , SubMenuItem , SeparatorItem ) that can be added to a ContextMenu object.