NonContinuousRailStructure Class


Non Continuous Rail Structure Class

A class that represents a collection of Non-Continuous Rails being a part of Railing Type.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.Architecture NonContinuousRailStructure

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class NonContinuousRailStructure : IDisposable

The NonContinuousRailStructure type exposes the following members.

Properties
Name Description
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
Name Description
Public method AddNonContinuousRail Creates and appends a new Non-Continuous Rail to the Rail Structure. The new Non-Continuous Rail will have the given name, height and offset. It will have default profile and material ElementIds.
Public method Dispose Releases all resources used by the NonContinuousRailStructure
Public method GetNonContinuousRail Gets the Non-Continuous Rail object of specified index from the Rail Structure.
Public method GetNonContinuousRailCount Gets number of Non-Continuous Rails.
Public method IsValidNonContinuousRailProfile Checks whether the input id represents a profile which can be used as the profile of this non-continuous rail.
Public method RemoveNonContinuousRail Removes Non-Continuous Rail from the Rail Structure.
Top
See Also