BarTypeDiameterOptions Class


Bar Type Diameter Options Class

This class stores the diameter information from the RebarBarType.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB BarTypeDiameterOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class BarTypeDiameterOptions : IDisposable

The BarTypeDiameterOptions type exposes the following members.

Constructors
Name Description
Public method BarTypeDiameterOptions Constructs a new BarTypeDiameterOptions with default settings.
Public method BarTypeDiameterOptions(RebarBarType) Constructs a new BarTypeDiameterOptions copying the diameter information from the bar type.
Top
Properties
Name Description
Public property BarModelDiameter Represents the bar model diameter of the RebarBarType.
Public property BarNominalDiameter Represents the bar nominal diameter of the RebarBarType.
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public property StandardBendDiameter Represents the standard bar bend diameter of the RebarBarType.
Public property StandardHookBendDiameter Represents the standard hook bend diameter of the RebarBarType.
Public property StirrupTieBendDiameter Represents the stirrup/tie bar and hook bend diameter of the RebarBarType.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the BarTypeDiameterOptions
Top
Remarks
This class can be used to create a whole new set of diameter values for a RebarBarType. It can be used when copying the diameter information as a bulk of data from a RebarBarType to another. The new diameters can be set in the RebarBarType in the following way: 1. Create a BarTypeDiameterOptions object with the new diameters. 2. Set the new diameters in RebarBarType using [!:Autodesk::Revit::DB::Structure::RebarBarType::SetBarTypeDiameters(Autodesk::Revit::DB::BarTypeDiameterOptions ^diametersOpt)] . The method [!:Autodesk::Revit::DB::Structure::RebarBarType::SetBarTypeDiameters(Autodesk::Revit::DB::BarTypeDiameterOptions ^diametersOpt)] is responsible for diameters validation.
See Also