SolidCurveIntersectionMode Enumeration


Solid Curve Intersection Mode Enumeration

Represents the types of results available for calculating the intersection between a solid and a curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public enum SolidCurveIntersectionMode
Members
Member name Value Description
CurveSegmentsInside 0 The results will include only curve segments inside the solid volume. This also will include curve segments coincident with the face(s) of the volume.
CurveSegmentsOutside 1 The results will include only curve segments outside the solid volume.
See Also